Server requirement

PHP version 7.3 or newer is required, with the *intl* extension and *mbstring* extension installed.

Codeigniter 4 cannot run if your web server does not enable intl extension, php-json, php-mbstring, php-mysqlnd, and php-xml. You can check it in phpinfo, if one of the extensions is disabled, please activate it in the php.ini file.

MySQL (5.1+) via the MySQLi driver

For the details, please visit official documentation from Codeigntier


Important! Make sure you already enable all the PHP extensions required

My php.ini file at local server (XAMPP)

Alt for image

My PHP Extension at CPanel server

Alt for image

Installation

It is very easy to do the installation, follow the steps below

Application
Installation to server is a simple process that should not take more than a few minutes. The following installation guide will help you to install the app on your server.
  • Unzip Zip Package from Codecanyon
  • Upload the unzip Package folders into your server. Normally the folder index.php file will be at your root.
Database
Open file app/Config/Database.php and set your database settings.
								
public $default = [
	'DSN'      => '',
	'hostname' => 'localhost',	// change with your hostname
	'username' => 'root',		// change with your username
	'password' => '',		// change with your password
	'database' => '',		// change with your database name
	'DBDriver' => 'MySQLi',
	'DBPrefix' => '',
	'pConnect' => false,
	'DBDebug'  => (ENVIRONMENT !== 'production'),
	'charset'  => 'utf8',
	'DBCollat' => 'utf8_general_ci',
	'swapPre'  => '',
	'encrypt'  => false,
	'compress' => false,
	'strictOn' => false,
	'failover' => [],
	'port'     => 8083,
];
							

Import the database script import_database.php to your database.

Video installation